Delayed Radiology Results in VetConnect PLUS

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Apr 27, 2026 - 19:59 EDT

Update

We are continuing to monitor for any further issues.
Posted Apr 27, 2026 - 15:13 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 27, 2026 - 15:12 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 27, 2026 - 14:03 EDT

Investigating

You may experience a delay in viewing or receiving radiology results within VetConnect PLUS and your Integrated Practice Management Software. WebPACS can be accessed directly to view any radiology results in the interim. As always, IDEXX appreciates both your business and your patience. We apologize for any inconvenience this may cause and will post an update as soon as we know more.
Posted Apr 27, 2026 - 14:02 EDT
This incident affected: VetConnect PLUS (Diagnostic Results, Web, Mobile).