DVMIinsight - Errors while navigating through the application

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Feb 06, 2026 - 13:34 EST

Investigating

Users are experiencing errors at login, and while navigating through cases.
Posted Feb 06, 2026 - 12:19 EST
This incident affected: Telemedicine (DVMInsight).