Vello Text Messages & Requests Page Not Automatically Refreshing

Incident Report for IDEXX Software

Update

We are continuing to investigate this issue.
Posted Mar 28, 2025 - 13:10 EDT

Investigating

We are aware of and investigating an issue impacting the Text Messages & Requests page. Currently the page may require a manual refresh to see latest messages or updates.
Posted Mar 28, 2025 - 13:09 EDT
This incident affects: Vello (Texting Services).