ezyVet Third Party Integration Issue - Provet

Incident Report for IDEXX Software

Resolved

The issue affecting B2B ordering with Provet has now been resolved. The disruption was caused by a brief third-party outage earlier today, which impacted our integration.

We apologise for the inconvenience and appreciate your patience.
Posted Jun 30, 2026 - 00:01 EDT

Investigating

Provet, one of our third-party integrations, is currently experiencing an issue with its integration. This is affecting the ability to validate integration, send orders or link products in ezyVet. Please contact Provet directly for further details.
Posted Jun 29, 2026 - 19:41 EDT