We continue to investigate an issue affecting integrated payment processing within Cornerstone, specifically impacting online payment requests, CareCredit transactions, and Card on File workflows.
Customers may experience transaction failures, delayed responses, or inconsistent payment statuses when using these payment methods.
At this time, our investigation indicates this issue is likely related to an external service disruption, and we are actively working with the appropriate partners to confirm scope and resolution.
Recommended Workarounds: Credit Card (CardConnect): Practices can continue processing payments directly through their payment terminals. Terminal-based transactions are not impacted.
CareCredit: Practices can process transactions via the CareCredit Provider Center: https://www.carecreditprovidercenter.com/ Payments can then be recorded in Cornerstone as an offline payment to ensure the client’s account remains accurate.
Our engineering teams are actively monitoring the situation and will provide updates as more information becomes available.
Posted Mar 31, 2026 - 15:04 EDT
Investigating
We are currently investigating an issue affecting integrated payment processing within Cornerstone, specifically impacting online payment requests, CareCredit transactions, and Card on File workflows.
Customers may experience transaction failures, delayed responses, or inconsistent payment statuses when using these payment methods.
Our engineering teams are actively working to identify the root cause and implement a resolution. We are also continuing to validate the full scope of impact across all affected payment types.
We will provide updates as more information becomes available.
Posted Mar 31, 2026 - 13:09 EDT
This incident affects: Cornerstone (Online Payments).