IHD Ordering Delay
Incident Report for IDEXX Software
Resolved
This incident has been resolved
Posted Oct 21, 2024 - 19:00 EDT
Update
We are still investigating the issue.

We will provide an update no later than 5:00 pm ET on Monday, October 21st.
Posted Oct 21, 2024 - 16:39 EDT
Update
We are still investigating the issue.

We will provide an update no later than 4:00 pm ET on Monday, October 21st.
Posted Oct 21, 2024 - 15:16 EDT
Investigating
You may experience a delay when submitting an IDEXX In House Diagnostic (IHD) Order within your Practice Information Management Software. Our team is investigating the issue.

As always, IDEXX appreciates both your business and your patience. We apologize for the current interruption in the ability to order IDEXX In House Diagnostics and for any inconvenience this may cause.

We will provide an update no later than 3:00 pm ET on Monday, October 21st.
Posted Oct 21, 2024 - 13:11 EDT
This incident affected: VetConnect PLUS Ordering (VetConnect PLUS Ordering).